JCUDigitalPortal Issues with Chrome Version 117
Incident Report for John Carroll University
Resolved
Our IT team has worked diligently to address the issue with Chrome Version 117, and we can confirm that JCUDigitalPortal is now fully functional across all supported browsers, including Chrome Version 117

If you encounter any further issues or have any questions, please do not hesitate to reach out to our ITS Service Desk at 216-397-3005 or via email at servicedesk@jcu.edu.
Posted Oct 06, 2023 - 08:54 EDT
Investigating
JCUDigitalPortal is not functioning correctly with Chrome Version 117. However, it is important to note that older versions of Chrome are unaffected, and the portal remains fully accessible on other popular browsers such as Edge, Firefox, Safari, and Opera.

We understand the inconvenience this may cause and sincerely apologize for any disruption to your workflow or access to JCUDigitalPortal.

For the most up-to-date information on this issue, please refer to our ITS Status Page at https://status.jcu.edu. Our dedicated team is actively working on resolving this compatibility problem, and we will provide updates on the ITS Status Page as soon as they become available.
Posted Oct 05, 2023 - 10:11 EDT
This incident affected: Computer & Device Support (Virtual Desktops).