RESNET Network Issue in Campion Hall
Incident Report for John Carroll University
Resolved
JCU ITS has confirmed that all network issues have been restored. ITS apologizes for any inconvenience caused by this issue and will continue to monitor the situation.

If you are still experiencing any network issues, please contact the Service Desk at 216-397-3005.
Posted Apr 26, 2021 - 18:01 EDT
Investigating
Information Technology Services (ITS) is currently experiencing RESNET network issues in Campion Hall. ITS is aware of the problem and is investigating.
Please contact the ITS Service Desk at x3005 or servicedesk@jcu.edu with any questions or concerns.
Information Technology Services

sites.jcu.edu/its
216-397-3005
Posted Apr 26, 2021 - 15:45 EDT
This incident affected: Network (Wired/Wireless) (Residence Halls).