Turnitin degradation issue
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 13:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2020 - 11:43 EDT
Investigating
Turnitin and iThenticate are currently experiencing an unexpected service disruption.

During this time, you may find that you are unable to access these services or experience degraded performance once logged in.
Posted Apr 21, 2020 - 10:43 EDT
This incident affected: Teaching & Learning Tools (Turnitin).