Turnitin degradation issue
Incident Report for John Carroll University
Resolved
We are pleased to advise that the service degradation experienced has now been resolved and submissions are processing within usual timeframes.
Posted Apr 20, 2020 - 14:32 EDT
Investigating
Turnitin currently experiencing intermittent service degradation resulting in slow logins to Turnitin. Our vendor is currently working on this issue to restore normal service.
Posted Apr 20, 2020 - 13:30 EDT
This incident affected: Teaching & Learning Tools (Turnitin).